Investigating Intermittent Global Connectivity

Incident Report for Creovai

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 19:52 UTC

Monitoring

Nameservers are recovering, most customer should be operation now.
Posted Feb 10, 2026 - 19:39 UTC

Identified

Our upstream provider has initiated restoration of their back-end infrastructure. And is expected to bring services back online shortly.
Posted Feb 10, 2026 - 19:05 UTC

Investigating

We are currently investigating reports of intermittent connectivity issues affecting our services globally. Users may experience slow loading times or occasional "connection timed out" errors. Our team has identified a potential networking issue and is working toward a stabilization fix. We will provide updates as we progress.
Posted Feb 10, 2026 - 17:15 UTC
This incident affected: Tethr Web Portal (Insights and, Search & Browse, Core) and Interaction Upload APIs.