Processing Delays
Incident Report for Creovai
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 16:58 CDT
Investigating
We’re currently experiencing a processing delay impacting some customers. Our team is actively working to resolve the issue. Thank you for your patience; we’ll provide an update as soon as possible.
Posted Sep 13, 2024 - 14:25 CDT
This incident affected: Tethr Web Portal (Insights and, Search & Browse) and Interaction Upload APIs, Data Processing, Notification.